Game issues with Windows 10



  • So I am putting the sims on my family's gaming computer and This happened:
    alt text

    That is supposed to be appaloosa plains. At first I thought it was a mod or something, but I remembered that this PC runs on Windows 10 and sims and windows 10 don't get along. I have no idea how to fix it. It is fine when you zoom into a lot, but if you are in town view this happens. Obviously, you could see how it gets really annoying and why I would like to fix it. If you guys could give me a hand on how I would go about fixing this I would be so grateful.


  • Breed Committee

    When you took this picture, there were horses and sims in the world (your stables' horses)? If not try rebooting your computer and creating a new game with that world again. This has helped me sometimes when getting that error.



  • Its a completely fresh game. I'm still in the process of downloading content to that computer. It was just the base game and pets when I took that and the only sims that were in the game were the default ones that the game puts in. Ive tried rebooting the computer, and starting the game over and it didn't help. Its like this on every world I try using.



  • Still looking for help. Now I cant open CAS if I have saved sims in the game. I have to delete them from the SavedSims file or it just wont open CAS. Ive tried waiting for over an hour and it wouldn't load. This is a huge problem.



  • I don't know if you tried this, but try to run game in compatibility mode. I have w10 and my game runs fine. But I have a gaming pc that was built to run the Sims and games like it. I also have a game that I can only play in compatibility mode or it does not run. I hope that helps.



Looks like your connection to EQUUS | Forum was lost, please wait while we try to reconnect.