Please Help(closed)



  • I keep trying to start up my game and this is the error message I get.
    Is this because I had to reinstall my stuff with the product codes via origin?
    The error is Service Initialization x0x175d824 and I tried running as administrator, I tried the super patcher but it did nothing but take it from 1.69 to 1.67. I really want to play again but I can't even launch the game to start over :(



  • Is your game original or downloaded?



  • Did you install them via origin downloads or a CD? If origin download I would try installing them via CD instead. Origin sucks. lol.





  • I have the disks and used them, but I lost all product keys on my move from my families place to my current one. So I had to ask EA and they gave me new keys after confirming I purchased these games legally(I had to re-register the codes for download completionšŸ˜¬). But every single time it makes me go through origin to launch the game, its a dang mess.
    I really don't want to reinstall because I'm not sure if it will allow me to use these product keys again, it betteršŸ˜’
    This is a clean install, I haven't put any mods, custom content etc. into the game yet and it still does nothing. Do you need my specs?



  • Will download CCleaner right now, I think we can rule out a memory/ram problem I have a very large portion to run on. My computer easily runs DA Inquisition plus all expansions on high,
    DoTA, and several other games.



  • I too can run a lot of games on high spec such as Witcher 3, Dragon Age Inquisition, Assassins Creed etc, but I too have had issues with Sims 3 crashing and I did read somewhere that Sims 3 does suffer from a memory leak. As for reinstalling I too lost all my registration numbers, so this time I just downloaded and installed all my Sims 3 through Origin as I'd registered all my games through the sims 3 website, so you shouldn't have a problem if you need to reinstall, plus you can get on and do other stuff, whilst it's downloading/installing, as you haven't got to sit and wait to change discs :wink:



  • Yeah its a nightmare with Origin right now, I used Ccleaner, tried to reinstall, and it won't download direct from Origin uggh.



  • At work, but I'm setting up a spec list, my windows used to be 7 but now its 10.

    16.0 GB Ram

    AMD Ryzen 3 1200 Quad-Core Processor 3.10 GHZ

    Windows 10
    64 bit



  • Hi Katie, here's a link you may find interesting. http://sims3cchunt.tumblr.com/post/169388498417 Also this program is a must-have! if you don't know about it already. http://linna.modthesims.info/download.php?t=416883



  • Ooh yes Susie I need that thank you I will try that!



  • Not sure what else to do I tried super patching, using the patch checker, updating my computer and it comes up with the same error. I spent a long time last night trying to get this to work and there is something wrong with it, I can't bypass the launcher because of Origin. I also had to get new product keys through them. I got Sims 3 installed, no cc or anything in it just to test and still the same error.



  • Did you install via disc or Origin?



  • Origin and the 1.69 patch of Sims 3 are incompatible. And unfortunately there's nothing we can do about that other than try to get the discs and only use them or try your luck with Steam because the latest update pretty much married Sims 3 to Origin. I've had this problem for several weeks now and nothing I've done has worked so far because of the compatibility issue that's Origin's fault, not yours.



  • So I can't leave it patched at 1.67? I have all discs but I would need EA to give me a new product key for Sims 3 since I don't have one. I have product keys for all expansions though.



  • After being away from Sims for over a year, I've downloaded and installed Sims 3 through Origin with no problems and I'm running Sims 3 on windows 10.
    Katie, did you download the Patch Downloader from FordGT90Concept who also created the Crash Log Analyzer? as the patch program will show your product keys.



  • Check if this might help you: http://games4theworld.bestgoo.com/t752-the-sims-3-ultimate-fix-should-fix-most-of-your-problems

    It keeps my game running smooth after all updates, but I don't have Origin. And my game is patched at 1.67 so if you can go back an update it will work fine as well :)



  • Do not go past patch 1.67 - 1.69 is the devil patch



  • You guys are the best! I will try the ultimate fix, if that doesn't work hopefully I will reinstall at 1.67.



  • Just a quick update:
    So I uninstalled the game and it won't download through Origin so I will try one more time or seek out another avenue to download it properly.



  • Might just need to re-buy the CDs to get new codes etc. :(



Looks like your connection to EQUUS | Forum was lost, please wait while we try to reconnect.