Slack can't load

  • Hey,

    so for the past 2 days Slack won't load for me, I get this message:

    For some reason, Slack couldn’t load 😓
    We’re quite sorry about this! Before you try to troubleshoot, please do check — the problem may be on our end.
    A few things to try:
    Reload Slack, or even restart your browser.
    Test your connection to Slack’s servers.
    Make sure your security software isn’t blocking Slack.
    Check our Help Center for more details, or drop us a line.

    I have AdBlock but then paused it for Slack, but it worked with AdBlock before so...

  • Sometimes I have to completely re-boot my computer before it will work again. Have you tried that?

  • Administrators

    I'm sorry, but all I can say is that slack is definitely working as normal overall, and I hope you can get connected to it again without too much trouble.

  • Are you using slack through the app or browser? I'm using mine in app version and it works as it should without any issues.

  • Through the browser... :/ Will try again today.

  • What browser are you using? Have you tried maybe using another one?

  • Managed to fix it. Thanks guys!

  • how did you fix this? im getting the same issue, but its only with the equus slack... every other slack I use works perfectly fine, which seems a bit weird.

  • I cleared cookies and then in Chrome settings added onto the allowed cookies list.

  • will try this, thanks! <3

Log in to reply

Looks like your connection to EQUUS | Forum was lost, please wait while we try to reconnect.